Note Air - WiFi and BlueTooth connection problems

Comments

9 comments

  • Donut Pirate

    I got my new Note Air several months ago and was able to connect immediately to WIFI right out of the box.

    I recently updated to the latest v3.1 firmware and still connect 100% to WIFI networks.

    If you factory reset and still experience issues, I would suspect a possible hardware issue like you mentioned.

     

    0
    Comment actions Permalink
  • Ale.P

    Thank you for your message. In fact my Note Air does not want to connect to wifi networks or BT devices. Only a couple of times it was able to connect to the hotspot of my mobile phone for a very short time. I managed to install manually via usb the last 3.1 firmware, but again no improvements of the connectivitiy.

    I will try factory reset maybe, I guess I will loose all my PDFs and maybe also the last firmware upgrade?

    I have a question, is it true that the device only connect to 2.4Ghz networks? Because in the specs it is reported "2.4/5 Ghz WiFi".

     

    1
    Comment actions Permalink
  • Donut Pirate

    This reminds me, I need to back up my own docs!  ha ha.

    The Note Air is an android device so the firmware should remain at the last update applied.  That being said, I have not actually done a reset on my device so my statement is based solely on working with other android devices (phones and tablets).

    I checked my router when the Note Air was connected via WIFI and it reported connected at "5 GHz".

    0
    Comment actions Permalink
  • Ale.P

    Factory reset done, no changes observed.

    The device erratically connects to the wifi, for very short time. Upgraded to the latest firmware, still faulty.

     

    The device came with the google suite installed, maybe this is what causes the instability? Did not succeed having g-play working yet, I'll try to uninstall..

    Very frustrated. Feedback from Onyx is slow, as well as from the local reseller...

     

    0
    Comment actions Permalink
  • Ale.P

    Also with usb tethering, with the Note connected through usb to a laptop having hotspot enabled, the network does not work.

    This is strange, seems like a software issue?

    0
    Comment actions Permalink
  • Chenoa S.M.

    Hi Ale, I just got a new Note Air and am having the same experience. I am not able to connect to any wifi networks... So frustrating! Were you able to find a solution to this? The tablet is pretty much useless without wifi

    0
    Comment actions Permalink
  • Booxshop Service

    Dear customer,

    Thank you for contacting us and sorry for the inconvenience.

    In this case, you could try the following methods first and see if the problem can be resolved.

    1. Please check the network first, and the Boox e-readers officially support the 802.11b/g/n network and could not connect to networks over 2.4GHz.

    2. Please try to connect to another Wifi network, such as a mobile hotspot on your mobile phone or the McDonald's Wi-Fi.

    3. Please kindly check whether you have built a MAC whitelist on your router or not and whether your firmware is the latest one or not. If not, please try to update to the latest firmware first.

    4. Please try to reboot your device and your router first, and then please try to choose the network you have connected and press the “Forget” button, then please try to reenter the password to connect the network.

    5. If the problem still persisted, then please store the device to the factory default setting.

    *Please note that restore the factory default settings will delete all data and files in your device. Please backup all important info/dates before restoring the factory default.

    For detailed info on factory reset, please check the link below:

    https://help.boox.com/hc/en-us/articles/360027488972-If-my-Boox-device-is-bricked-what-should-I-do-

    Thank you for your time and understanding and hope it helps

    0
    Comment actions Permalink
  • Tom Eden

    I've been having this problem for about a month and have finally realised the date and time had somehow gone to a random time about a year ago and once I fixed this everything worked fine again

    1
    Comment actions Permalink
  • Mario Stenger

    I've been having this problem for about a month and have finally realised the date and time had somehow gone to a random time about a year ago and once I fixed this everything worked fine again

    That was exactly the solution for me as well.
    Many thanks for this!

    0
    Comment actions Permalink

Please sign in to leave a comment.