Skip to main content




  • Christina Marshburn

    I am having the same issue! I just got the NoteAir 2. I was FINALLY able to Google Play services to work so I downloaded the kindle app from the Google Play store. I can log into my amazon account but it will not sync. Please someone from Boox help!

  • Chris

    In the end I got it to work by going back to factory settings, then downloading the kindle app immediately from the Boox apps, not from the Google Play store. Then everything worked. I had spent DAYS trying everything else and was ready to send the NoteAir2 back. But finally, this worked. 

  • Christina Marshburn

    I downloaded the kindle app first from the Boox apps and it didn’t work, that’s why I went and re-did it from the Google play store. Did you have trouble connecting to google play services after the factory reset? And did you update the firmware?

  • Rupert Baines

    I am sorry - this is frustrating answer 

    I do not know *how* I did it, but I did and it works fine. I do not remember it being frustrating...

    I hesitate to say that because it will be frustrating for you - but on the other hand it is encouraging because it is possible - it *does* work. I have been happily reading my Kindle library. Like you this was a reason I bought the NOTE 

    Int looks like I did it via Google Play store

    Hope thast you got it sorted


Please sign in to leave a comment.