Skip to main content

Unable to make notes or highlight text in Neoreader



  • Booxshop Service

    Dear customer, we apologize for the inconvenience.

    In this case, please try to turn off the V2 engine first, and turn it back on. After that, please check if the problem can be solved. You could follow the steps below to turn on/off the V2 engine

    If still not working, we appreciated it if you could take a video of this issue. And then, please submit a request here and attach the video to it. Our after-sale team will check for you and get back to you asap.

    Many thanks for your effort and understanding.

  • Stéphane Couture


    I also have this problem since my last update to 3.3.1. I tried what what suggested, but it didn't work.

    I also this problem since my update. Basically, but boox note is close to useless now. 

    Stéphane Couture

  • Brian C

    Stéphane - My solution ended up being resetting the Boox to factory settings and the reloading my apps and documents. I was fortunately at a place where it wasn't too much hassle for me to do it. I wasn't able to figure it out otherwise.

  • Luca Forgiarini

    I have the same issue, having recently upgraded to the latest firmware (which includes NeoReader 3). Basically, I can make the selection for the highlights fine but as soon as I tap outside the box to save the highlight, it just disappears. I've tried turning the V2 engine option off but that does not seem to work.

  • Tobias

    I have this issue also, this is an important feature, please find a fix as soon as possible


Please sign in to leave a comment.