Google Play Store not working

Comments

5 comments

  • Official comment
    BOOX Support

    Hi,

    Thanks for your post here!

    You are suggested to go to this link and learn how to active your Google Play first.

    https://help.boox.com/hc/en-us/articles/360027487672-How-to-activate-the-Google-Play-

    Thanks for your support!

    Comment actions Permalink
  • ioan dorin pana

    I have the same issue. I have tried all the instructions as per the video but with no success. The Nova 2 it's updated with the newest firmware and have followed the exact steps and registered the android device to my google account.

    It DOESN'T work and this is beyond frustrating since its a new device that's quite expensive

     

    HELP URGENTLY

    0
    Comment actions Permalink
  • Nashafitter

    I'm still stuck. Boox will not let me return it. Their response is to continue asking questions on this community forum. I've spent 10 hours trying to make this machine work. Really disappointed in the product quality and also customer relations in refusing a return/making it a major hassle. 

    0
    Comment actions Permalink
  • John

    I hope your issue has been fixed now, if it hasn't, try:

    Factory Reset
    Firmware Update (manually if the automatic OTA one doesn't work)
    Reboot

    The reboot is absolutely necessary after getting the device registered at Google, also for the regular activation.

    0
    Comment actions Permalink
  • Taye B Taye

    I had issues as well but these steps have worked for me. Try them out.

    After going through the established 'Enable Google Play' then doing the GSF ID, I restarted a couple of times and no luck but then I went to...

    Settings>Account Management>System Account Settings>Manage
    And signed into my google account to establish my google account under 'Accounts for Owner'. The app seems to work and I was able to download my manga app from the store as of June 18th 2020.

    Hope this works and thanks for the device guys.

    0
    Comment actions Permalink

Please sign in to leave a comment.